This is the installation instruction of IPP-2.6.1 for Mac OX 10.5.5 system. My gcc version is 4.2.2 and mysql is 5.0.51b. Error messages may be different due to system environment/setting. Before installing IPP, please make sure that there is installed mysql in your machine.

*Download IPP and its external library (extlibs & extperl) from IPP download page

http://pan-starrs.ifa.hawaii.edu/project/IPP/software/

*Expand tar balls under your install path

<pre> tar zxvf ipp-2.6.1.tgz tar zxvf extlibs-2.6.1.tgz tar zxvf extperl-2.6.1.tgz </pre>

*If the name of the directory of extlibs (or extperl) is NOT extlibs (or extperl), rename it with extlibs (or extperl).

<pre> mv extlibs-2.6.1 extlibs mv extperl-2.6.1 extperl </pre>

*Run bootstrap

<pre> cd ipp-2.6.1/psconfig (added by Colin Aspin)

./psbuild -bootstrap Your_INSTALL_PATH </pre>

*Edit .profile under your home directory. Add following text

<pre>

if [ -f /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/psconfig.csh ]; then alias psconfig='source /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/psconfig.bash'

else alias psconfig='echo psconfig not available'

fi

psconfig default

</pre>

Attention, .profile is .bashrc in Mac version. If you want to use tcsh or cshl, edit your .tcshrc or .cshrc file with

<pre> if (-e /Users/jbj/Research/Pan-STARRS/IPP/ipp-2.5/psconfig.csh) then

alias psconfig "source /Users/jbj/Research/Pan-STARRS/IPP/ipp-2.5/psconfig.csh"

else

alias psconfig "echo psconfig not available"

endif psconfig default </pre>

*Check libs under ipp-2.6.1/psconfig/

<pre> ./pschecklibs -build ./pscheckperl -build </pre> There are 2 problems occured when i did. My solutions are discribed in Known problems

*Install IPP

<pre> psbuild ipp-2.6.1 </pre>

==Known problems:==

==No libtool in jpeg-6b/ directory (added by Colin Aspin)== ltconfig can't guess what the host system is so make of the jpeg-6b/ lib fails.

Solution from Mark Huber:
Hi Colin - I also had the same problem with the libjpeg and couldn't find a solution, but manually building it seemed to work for me.

cd jpeg-6b; psconfigure; make; make install; make install-lib

ps. Josh Hoblitt says that the build should work on OSX IF there is no existing version of libtool installed on the system (e.g. fink, macports, etc).

12/11/08 - tried the CVS full install on Mac OS X 10.5.5. I got the above libtool error again but still got it after removing the exisiting libtools from /usr/bin/ and /usr/local/bin/. I had to copy the IPP version of libtools to the ~/extlibs/jpeg-6b/ directory for libjpeg to be created OK. However, next I got an error saying there was no ranlib available....

==Perl module error on DBD::mysql== It is an bug of DBD:mysql itself. For more information, check http://rt.cpan.org/Public/Bug/Display.html?id=28795

Solution:

*Go to http://search.cpan.org/~capttofu/DBD-mysql-4.007/lib/DBD/mysql.pm to download the latest version (4.007)

*Replace DBD module in your "extperl" directory with the new one.

*Edit dbdimp.h and add following text at line 24th

<pre> #if !defined(HAVE_ULONG) && !defined(TARGET_OS_LINUX) &&!defined(USE_MISC) typedef unsigned long ulong; /* Short for unsigned long */ #endif </pre>

*Back to psconf and ./pscheckperl -build

==error on psbuild== <pre> dhcp18:psconfig pschiang$ psbuild ipp-2.6

** psbuild: Ohana **

make

make libs exit mkdir -p /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/default.darwin_x86/include mkdir -p /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/default.darwin_x86/lib mkdir -p /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/default.darwin_x86/bin

for i in libtap libohana libfits libdvo libkapa; do make $i.install exit; done -n -e mkdir -p bin/darwin_x86 if [ -d "src/libtap" ]; then (cd src/libtap && make install); fi make[3]: Nothing to be done for `install'. -n -e mkdir -p bin/darwin_x86 if [ -d "src/libohana" ]; then (cd src/libohana && make install); fi make[3]: Nothing to be done for `install'. -n -e mkdir -p bin/darwin_x86 if [ -d "src/libfits" ]; then (cd src/libfits && make install); fi make[3]: Nothing to be done for `install'. -n -e mkdir -p bin/darwin_x86 if [ -d "src/libdvo" ]; then (cd src/libdvo && make install); fi make[3]: Nothing to be done for `install'. -n -e mkdir -p bin/darwin_x86 if [ -d "src/libkapa" ]; then (cd src/libkapa && make install); fi make[3]: Nothing to be done for `install'. chmod +x ohana-config cp -f ohana-config /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/default.darwin_x86/bin/

for i in addstar delstar dvosplit elixir gastro gastro2 getstar gcompare imclean imregister kapa2 misc mosastro nightd opihi perl relphot relastro shell tools tcl uniphot; do make $i exit; done -n -e make[2]: Nothing to be done for `default'. -n -e -n -e make[2]: Nothing to be done for `default'. -n -e -n -e -n -e -n -e -n -e -n -e make[2]: Nothing to be done for `default'. -n -e -n -e -n -e -n -e -n -e make[2]: Nothing to be done for `default'. -n -e -n -e -n -e -n -e -n -e

for i in mana dvo pantasks pclient pcontrol pantasks_client pantasks_server; do make $i exit; done if [ -d "lib.data" ]; then (cd lib.data && make); fi gcc -g -O0 -fPIC -DHAVE_MYSQL_H -I/Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/include -I/Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/default.darwin_x86/include -I/usr/include -I/usr/local/include -I/usr/X11R6/include -I/usr/local/include/mysql -Ddarwin_x86 -c /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/lib.data/book.c -o /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/lib.data/book.darwin_x86.o In file included from /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/include/data.h:2,

from /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/lib.data/book.c:1:

/Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/include/shell.h:126: 錯誤:expected declaration specifiers or 「...」 before 「rl_compentry_func_t」 /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/include/shell.h:126: 錯誤:與 「completion_matches」 類型衝突 /usr/include/readline/history.h:172: 錯誤:「completion_matches」 的上一個宣告在此 make[4]: *** /Users/pschiang/Downloads/ipp/ipp2.6beta/ipp-2.6/Ohana/src/opihi/lib.data/book.darwin_x86.o Error 1 make[3]: *** [lib.data] Error 2 make[2]: *** [all] Error 2 make[1]: *** [opihi] Error 2 make: *** [all] Error 2 problem building Ohana : failure in make dhcp18:psconfig pschiang$ </pre>

Well... the bug was fixed by Paul just on yesterday. To fix the bug, please recompling "readline" with following command: <pre> ./pschecklibs -build -force libreadline </pre>

You may also use the same command to rebuild other libraries by replacing libreadline with names of other libraries. After rebuilding readline, run psbuild ipp-2.6.1 to complete the installation. --Pschiang? 17:46, 1 August 2008 (CST)