Changes between Version 24 and Version 25 of IPP_Installation

Show
Ignore:
Timestamp:
06/25/2015 03:40:32 PM (2 years ago)
Author:
watersc1 (IP: 128.171.160.198)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • IPP_Installation

    v24 v25  
    5959= Nebulous Installation = 
    6060 
    61 == apache server installation == 
     61== Nebulous/Apache server installation == 
    6262 
    63 The  
     63The installation script and source tar.gz files needed for the apache configuration of nebulous are located in ~ipp/src/nebulous-apache-dependencies.  The README file contains instructions on executing the install-nebulous.sh script, which must be run as root to ensure that the installation is global (and therefore visible to the apache server).  The install-nebulous.sh script lists all the possible perl dependencies that are needed, but most have been commented out as they appear to be installed by default on the ipp cluster.  The only exception (as of 2015-06-25 and the installation on ippc20) is the Apache2::SOAP module.  This has been left uncommented so it will be installed.  The script will then copy the apache configuration files (which should be checked against those currently in use on the active apache servers) into place.  Finally, the Nebulous-Server package is exported from SVN and installed. 
     64 
     65At this point, the script stops and restarts the apache server, and assuming no modules are missing, the configuration can be tested by setting the NEB_SERVER variable (for the ippc20 install, {{{setenv NEB_SERVER http://ippc20.ipp.ifa.hawaii.edu/nebulous}}}) and executing nebulous script commands.  Errors of the sort: 
     66{{{ 
     67500 Internal Server Error at /home/panstarrs/watersc1/ipp/install/default.lin64/lib/Nebulous/Client.pm line 1325 
     68}}} 
     69suggest a missing perl module on the server, and for this installation, /var/log/apache/error_log pointed to the problem: 
     70{{{ 
     71[Thu Jun 25 15:20:55 2015] [error] [client 10.10.20.80] failed to resolve handler `Apache2::SOAP': Can't locate Apache2/SOAP.pm in @INC (@INC contains: /home/httpd/perl /etc/perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux /usr/lib64/perl5/vendor_perl/5.8.8 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux /usr/lib64/perl5/site_perl/5.8.8 /usr/lib64/perl5/site_perl /usr/lib64/perl5/5.8.8/x86_64-linux /usr/lib64/perl5/5.8.8 /usr/local/lib/site_perl . /usr/lib64/apache2) at (eval 133) line 3, <DATA> line 13.\n 
     72}}} 
     73 
     74 
    6475 
    6576= Notes =